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This tutorial shows how to use Roy Harrington’s “Create ICC-RGB” to make ICCs 
that can control B&W inksets that utilize Photoshop curves.  These include the 
new UT-3D as well as other variable-tone inksets and older monotone inksets 
with partitioning curves. 
 
Using the “Create ICC-RGB” program, the basic process is to embed the 
Photoshop curve into the ICC as well as the information about the densities that 
curve prints on the targeted paper using the curve.  To do this, one makes 2 files 
– one with the curve color information and one with the density information – and 
then drags and drops them into the Create ICC-RGB icon on the Desktop.  While 
the process may seem complex at first, it is really very simple, especially if one 
has a good instrument for reading the required test strip and the Photoshop 
curve is already made. 
 
This ICC approach works for not only the variable-tone inksets like the new UT-
3D or older UT2, but also older partitioned monotone inksets.   
 
Once complete, the ICC in the printing workflow will take care of both converting 
the grayscale file to RGB, applying the curve, and linearizing the output to match 
the monitor, taking into account the variables of the particular printer, paper and 
ink batches.       
 

Downloading the Create ICC Program 
 
This workflow requires that the user purchase a copy of Roy Harrington’s “Create 
ICC,” which is part of the QTR package found at 
http://www.quadtonerip.com/html/QTRoverview.html .  When the appropriate 
version is downloaded and installed the “Create ICC” components will end up in 
Program Files\QuadToneRIP\Eye-One folder for Windows, CurveDesign/Eye-
One for Mac. 
 
There are actually two versions of “Create ICC” in the folder.  One passes a 
grayscale file to the driver and the other handles RGB curves and passes an 
RGB version to the driver.  It is this later one that we are interested in for the 
workflow described here.  So, put a copy of the “Create ICC-RGB” program on 
the Desktop.  It is there that the ICCs are made.  
 



Place the Curve on the Create ICC-RGB Raw File 
 
The variable-tone or partitioning Photoshop (*.acv) curve you want to print with 
needs to be put on a Photoshop Raw (*.raw) file for embedding.  Use the small 
file “rgb-raw-16.psd” that is contained in the Eye-One folder, noted above.   
 

 
 
Open this file in Photoshop and place the curve on it in the usual manner 
(Image>Adjust>Curves>Load …).  In Elements you’ll need to have the curve on 
an adjustment layer.  Then you can drag it to the rgb-raw-16.psd file.  If the curve 
that you’re interested in is not posted on a layer, e-mail me and I’ll send it. 
 
The file is then saved as a “Raw” file on the Desktop.  Use an appropriate name 
for the file that tells you what it is for.  I tend to do the following for naming: 
“Printer_Inkset_Paper_Curve-tone.”  Sometimes I’ll add settings if they are 
different than usual for the particular inkset. 
 
When I save one of these files on my Windows system, the only non-default 
setting is that the Byte Order is “IBM PC.”   Other than that I simple hit OK with 
the suggested settings. 
 
Once you’ve done this once, it takes about a minute to open the file, place the 
curve on it, and save it to the Desktop. 
 

Print a 21-Step Test File with the Curve 
 
The Photoshop curve must also be used to print a test strip on the paper that is 
being profiled.  Use the settings and procedures that are outlined in the Readme 
file for the inkset and paper type.  The same driver settings will be used once the 
ICC is made.  I always use working space Gray Gamma 2.2, and it appears that 
this workflow requires the test strip to be in that space.  Be sure the test strip is 
dry before reading it.  I use a hair drier. 
 
 

 



 
A 21-Step test file with Gray Gamma 2.2 profile has been posted here:  
http://www.paulroark.com/BW-Info/21-Step-GG22.html    
 
 

Make a Text File of the Lab L* Readings from the above Test 
Strip 
 
The Create ICC program linearizes the system by taking the readings from the 
21-step test strip and correcting for differences from the ideal distribution of 
densities.  So, the 21-step test strip must be measured to see what the printer 
without these corrections is doing.  The measurements are put into a text file in a 
particular format so that the Create ICC program can read them. 
 
This is the format that I use when making the text file manually with my X-Rite 
spectrophotometer (the columns are separated by a Tab, with a return/enter at 
the end of each line): 
 
Gray Lab_L 
0.00 97 
5.00 92 
10.00 87 
15.00 83 
20.00 79 
25.00 74 
30.00 71 
35.00 67 
40.00 63 
45.00 59 
50.00 55 
55.00 50 
60.00 45 
65.00 40 
70.00 34 
75.00 30 
80.00 26 
85.00 22 
90.00 19 
95.00 17 
100 15 
 



With the ColorVision Print Fix Pro (“PFP”) spectro I am currently using (with 
software version 1.1b7), this is a sample text file it produces when I start at 0% 
and read consecutive test strip patches down to 100% (takes less than a minute): 
 
95.43 0.8 1.06 
90.13 0.82 0.66 
85.65 0.87 0.91 
81.22 0.84 0.97 
77.73 0.87 0.86 
74.31 0.86 0.91 
71.32 0.83 0.88 
68.09 0.92 0.8 
65.07 0.89 0.94 
61.15 0.9 0.94 
57.06 0.85 0.89 
51.25 0.82 0.76 
46.43 0.81 0.99 
41.91 0.8 0.96 
36.48 0.74 0.9 
31.02 0.6 0.92 
25.14 0.71 1 
18.79 0.76 0.99 
10.9 0.27 0 
7.18 -0.18 -1.26 
5.11 -0.41 -1.02 
 
Both of these formats work with the program.   The PFP output includes Lab a* 
and b* data, but this is ignored by the program for printing purposes.   
 
(The program does take the color information if there are headings added to the 
columns: LAB_L, LAB_A, and LAB_B (or simply L, A, and B).  This information 
can then be used for soft-proofing, but I am not dealing with that subject here and 
do not use it.) 
 
For those who have densitometers, another option is to use density values.  They 
should be between 0.00 and 4.00; a heading of D, Dens, or Density works for 
this. 
 
Those with spectros that read strips can usually generate text files like this also. 
 
For those who do not have a spectro but do have a flatbed scanner, the test strip 
can be read and text file made using the procedure I’ve outlined at 
http://home1.gte.net/res09aij/Making_B-W_ICCs.htm .   
 
Save the text file to the Desktop with a name that is similar to the curve used to 
generate it. 



 
With the ColorVision spectro it takes me less than a minute to read the 21-step 
test file.  It makes the text file automatically.  At about $500, it seems like the best 
buy.  The Eye-One would be the next step up. 

 
Drag and Drop the Text File and Raw File into the Create ICC 
Program 
 
With the raw file and text file on the Desktop, the Create ICC-RGB has all the 
information it needs to make an ICC.  The raw and text files are simply dragged 
and dropped into the Create ICC-RGB program at the same time.  (Click on one, 
then control-click on the other, then with the control key down, drag the 2 icons to 
the Create ICC-RGB icon.)  On my Windows system a white bar appears over 
the Create ICC-RGB program when the other files are on top of it. 
 
The Create ICC-RGB program will generate an output text file that you’ll see 
immediately.  This as well as the ICC should be on the Desktop.  I discard the 
text files. 
 
The ICC is then placed in the usual Color folder with your other ICCs. 
 

How to put the ICC in the correct folder -- Windows XP  

 

ICCs are put in the following Windows XP folder:  

c:\windows\system32\spool\drivers\color\  

I recommend you highlight and copy this c:\ ... \color path and make a folder 
shortcut on your Desktop that allows you to simply drag the ICCs to the shortcut 
to put them into the correct folder location. This is the procedure to make such a 
folder shortcut: 

1. Right click on the Desktop (anywhere on your computer monitor where no icon 
appears and when no program is running there.  

2. On the menu that appears, highlight "New."  

3. On the new menu that appears, click on "Shortcut."  

4. In the space where it asks you to type in the location, copy & paste, or type in 
the full path:  

c:\windows\system32\spool\drivers\color\  

5. Click on the Next button. "Color" should appear in the box. You might want to 
also add "ICCs" to this name so that it reads, "Color (ICCs)."  

6. Press "Finish" and a folder icon should appear on your Desktop. This is a 
shortcut to the proper folder.  



To use this, simply drag the ICC icon that has been saved to the Desktop over to 
the Color (ICCs) shortcut folder icon. The ICC icon should be transferred to the 
proper folder.  

Note that if Photoshop Elements has already been opened, it will not "see" the 
new ICCs until the Color Settings box (Edit>Color settings) is opened and closed.  

 

Location of ICCs in different OSs  

Mac OS 9.x: -- Systems Folder/ColorSync Profiles  

Mac OS X -- Library/ColorSync/Profiles  

Windows 98/M --: \Windows\System\Color  

Windows NT/2000 or XP upgrade from NT/2000 -- 
\Winnt\system32\spool\drivers\color  

 

Using the ICCs for Printing 

 

If Photoshop was already running when the ICC was put into the Color folder, it 
will not be seen.  Click on Edit>Color Settings to refresh the ICC list. 

 

The basic workflow is to print through the Photoshop Print Preview (File>Print 
with Preview).  PS Elements 4 always utilizes a print preview. 

In the box that appears below the Preview image, check “Show More Options” 
Select “Color Management.”  In CS2 select “Let Photoshop Determine Colors” in 
the Color Handling box.  Then click the arrow to right of the “Printer Profile” to 
show the list of ICCs.  ICCs that are made with the Create ICC programs will all 
start with “QTR” and be grouped together on the list. 

 
The lower part of the Print Preview box in CS2 is shown below (after an ICC has 
been selected). 
 



 
 
Note that Perceptual and Black Point Compensation are selected. 
 
When one pushes the “Print” button in the Preview, the usual Epson driver boxes 
appear.  Use the settings that were originally specified for the inkset-paper-curve 
combination and were used when the ICC was made. 
 
This should result in a print that has the tones that are set by the curve and a 
density distribution that is determined by the gray working space.  This density 
distribution may, however, be different than what was being used previously in 
the workflow that had the file converted to RGB and curve applied in Photoshop. 
 

Gray Working Spaces and Density Distributions 
 
I use and recommend others use Gray Gamma 2.2 and Adobe RGB (1998).  
These are set in Edit>Color Settings.  The Create ICC-RGB appears to require 
Adobe RGB.  Gray Gamma 2.2 is the most common grayscale space, is a subset 
of Adobe RGB, and is what the Web uses.  So, there are a number of reasons to 
use these spaces. 
 
My older workflows used a different density distribution or grayscale ramp than 
Gray Gamma 2.2.  To get the monitor to match the print, I used a custom dot 
gain curve in Photoshop.  The use of ICCs avoids the need to do this, but my old 
files now need adjustment for the new printing approach.  To make this easier, I 
made a curve that can be used as a layer on the file for this purpose.  If the file is 
16 bit, it is likely no significant information is lost.  Aside from the obvious (0, 0) 
and (255, 255) end points, there are just four internal points on this grayscale 
curve: (12, 34), (25, 50), (63, 82), and (128, 153). 
 



Using Gray Gamma 2.2 (“GG 2.2”), I found that the 95% to 100% densities are 
very compressed.  At first that seemed like a waste of limited grayscale space, 
but with a 16 bit file, it’s insignificant. 
 
What I’ve also found is that, especially with the high dmax glossy papers, while 
the 95% - 100% densities look virtually the same in normal office or home 
lighting, outside or under a good spot light the very deep shadows that looked 
totally black open up and the full range is visible.  The differences between a 
matte paper with a 1.6 dmax and a glossy paper with a 2.3 dmax also becomes 
very obvious.  The higher dmax papers look much better with good lighting. 
 
The downside of this is that when working in GG 2.2 I’ve missed things going on 
in the shadows because my monitor did not display them well.  While I thought 
the image was ready to go, and while it looked fine under normal office lighting, 
under a spotlight or outside defects in the shadows became apparent.  What I’ve 
done to avoid this is temporarily switch the gray working space to Dot Gain 20% 
and check the shadows.  The shadow detail that is only visible in that Dot Gain 
20% may not show when printed in GG 2.2 and viewed under normal lighting, but 
under a spot or outside the additional detail – and defects – will become visible.   
 
To switch working spaces in full Photoshop you can use Edit>Assign Profile.  
(Don’t convert the profile because it will affect the file values as well as the view.)  
 
In Elements the controls in Edit>Color Settings are used.  If the file was opened 
when “No Color Management” was checked in Color Settings it will be an un-
tagged file.  Un-tagged files display as GG 2.2 by default.  With this type of file 
you can switch the view to Dot Gain 20% by going to the Edit>Color Settings 
menu and checking “Always Optimize for Printing.”  I would not save or print the 
file with this setting, however. 
 
That’s it for now.  Good luck with your printing. 
 
 
To return to my index of printing information, click here: 
 http://www.paulroark.com/BW-Info/  
 
To go to my photographic home page, click on the link below. 
 
 
Paul 
www.PaulRoark.com  


